engage mob success should be 100% when not engaged

Please post your ideas to improve our mud.

engage mob success should be 100% when not engaged

Postby cnl » Fri May 13, 2022 2:52 pm

This is a pretty minor inconvenience, but my suggestion is if using engage to start fighting a mob, and player is not already in combat, I suggest the success rate should be 100%

It makes sense that if switching targets that there should be a failure rate, but sometimes I initiate combat with engage mob when not fighting anyone and it's rather funny that I fail. Maybe Fuligin is pretty near-sighted and attacked the bushes instead? haha

I use engage instead of assist, or sometimes engage just to start battles. I just want status to be fighting but not necessarily be lagged.

Assist gets you a quick hit on the mob but lags you until the next round of combat, engage has you enter combat but take no action until the next round of combat give me a moment to choose an action if wanted.

thanks
cnl
40 Prime Poster
 
Posts: 58
Joined: Wed Oct 21, 2020 12:16 am
Status: Offline

Re: engage mob success should be 100% when not engaged

Postby Driven » Sat May 28, 2022 12:29 pm

I know failing engage is somewhat annoying, but there is no lag on a failed engage, which means you can just do #3 engage target. Is there some reason why this doesn't work? You can build this into your client. Maybe I'm missing something other than the annoyance factor?
Driven
Double 40 Poster
 
Posts: 176
Joined: Wed Feb 02, 2005 12:14 pm
Location: Raleigh, NC
Status: Offline

Re: engage mob success should be 100% when not engaged

Postby cnl » Sat May 28, 2022 4:03 pm

#3 engage is a good idea, i'll try that.
cnl
40 Prime Poster
 
Posts: 58
Joined: Wed Oct 21, 2020 12:16 am
Status: Offline

Re: engage mob success should be 100% when not engaged

Postby cnl » Sun May 29, 2022 10:29 pm

I tested this some and although the command has no lag it introduces 500ms of latency. (or 250ms per attempt)

I didn't test that much but ran into a few cases of double failures so the failure % is relatively high.
I'm assuming I'll run into triple failures on occasion

Code: Select all
You failed to get your attack in.Engage @:0.4210000038147
<1095hp 2103ma 388mv -% @0>
[12:49 pm] (fair) -10 9646710334
You failed to get your attack in.Engage @:0.64000010490417
<1095hp 2103ma 388mv -% @0>
[12:49 pm] (fair) -10 9646710334
You turn your attacks toward a female citizen [target].Engage @:0.89000010490417


I think I'll just settle on a trigger based approach since it may have more latency but most of the time 1st will take anyway
cnl
40 Prime Poster
 
Posts: 58
Joined: Wed Oct 21, 2020 12:16 am
Status: Offline


Return to Mud Suggestions

Who is online

Users browsing this forum: No registered users and 0 guests

cron