MSDP Broken Since Reset?

Use this forum for general discussions

MSDP Broken Since Reset?

Postby Gorka » Mon Sep 06, 2021 4:14 pm

Code: Select all
Welcome back Gorka!  Press return to continue...

Reconnecting.

<1883hp 852ma 655mv -15.0ac Settlestone 51807024724xp -%>

^[F210][^oINFO^[F210]]^n MXP version 1.0 detected and enabled.


None of my MSDP is working since reset.
Gimme a G! Gimme a ORKA!
User avatar
Gorka
Avatar Poster
 
Posts: 667
Joined: Tue Jul 12, 2016 5:50 am
Status: Offline

Re: MSDP Broken Since Reset?

Postby Gorka » Mon Sep 06, 2021 5:25 pm

Turns out a setup trigger wasn't firing due to the Arglebargle, glop-glyf!?!

I fixed the trigger and everything now works... however I think the issue on login should be fixed also.
Gimme a G! Gimme a ORKA!
User avatar
Gorka
Avatar Poster
 
Posts: 667
Joined: Tue Jul 12, 2016 5:50 am
Status: Offline

Re: MSDP Broken Since Reset?

Postby cnl » Mon Sep 06, 2021 9:31 pm

I have mxp disabled in mudlet settings because it's buggy

Options > Preferences > Special Options > Force MXP Negotiations Off

I turn on MSDP on the following 2 triggers since doing so makes the MXP message not show up.

Code: Select all
Welcome to the land of SlothMUD. May your visit here be... Interesting.
Reconnecting.


However, I agree something has changed with MXP on this latest reboot - even with it off I get the following message on channel who

Code: Select all
Here are the currently open channels.
Locked?  #Users  Name
------------------------------------
     No       5     <SEND "channel join slackers|channel who slackers" hint="Join slackers|Show members of slackers?">slackers   </SEND>


which looks like MXP plaintext mixed in for some reason even though I have it turned off, plus the weird login stuff you're seeing.
cnl
40 Prime Poster
 
Posts: 42
Joined: Wed Oct 21, 2020 12:16 am
Status: Offline

Re: MSDP Broken Since Reset?

Postby *teker* » Wed Sep 08, 2021 4:47 pm

I believe this will be fixed at next reboot. I was working on cleaning up some of the comm code (to try to figure out some of the MXP issues) and I think it accidentally got put into production.
*teker*
Triple 40 Poster
 
Posts: 298
Joined: Sun Apr 05, 2015 3:41 pm
Status: Offline

Re: MSDP Broken Since Reset?

Postby cnl » Sun Oct 10, 2021 3:16 am

is there something that has broken msdp for SAVING_SPELL in CHARACTER_AFFECTS for "item-generated'

I'm seeing entries for things like HEAL_BONUS but not for SAVING_SPELL.

eg
["0"] = {
DURATION = "-1",
LEVEL = "45",
MODIFY = "HEAL_BONUS",
PERMANENT = "1",
POINTS = "10",
SOURCE = "item-generated"
},

I rely on this ("item-generated" SAVING_SPELL) quite heavily.

EDIT: Did confirm with 2 9x40s that it's not showing properly for them anymore either.
cnl
40 Prime Poster
 
Posts: 42
Joined: Wed Oct 21, 2020 12:16 am
Status: Offline

Re: MSDP Broken Since Reset?

Postby Insomnia » Sun Oct 10, 2021 4:32 pm

Umm, how did you rely on a non-existent thing? Are you sure you're looking into the right place?

It never was on msdp.CHARACTER_AFFECTS with "item-generated". I think it appears there only in special cases with these sources (according to my logs): "fortune", "bless", "word of pain", "fare thee well" and "warcry".

I only use msdp.CHARACTER_STATISTICS.SAVING_THROWS.SPELL.MODIFIER – what's your use case?
Insomnia
 
Posts: 33
Joined: Tue May 19, 2020 7:56 am
Status: Offline

Re: MSDP Broken Since Reset?

Postby cnl » Sun Oct 10, 2021 8:18 pm

hmmm.. I think you're right. what the heck is my script doing.
it's definitely not working but maybe that has to do with reborn weirdness or eq not equipping that i expect to be equipped.

I have a set of functions that's going into a loop and I'm not sure why. One of its logic gate functions is

Code: Select all
function u.sumAffect(modify)
  local sum = {
    spell = 0,
    class = 0,
    item  = 0,
  }

  for k,v in pairs(msdp.CHARACTER_AFFECTS) do
    if v.MODIFY == modify then
      local key
     
      if v.SOURCE == "item-generated" then
        key = "item"
      elseif v.SOURCE == "class" then
        key = "class"
      else
        key = "spell"
      end
     
      sum[key] = sum[key] + tonumber(v.POINTS)
    end 
  end
  return sum
end

function u.sumAffectSavingSpell()
  return u.sumAffect("SAVING_SPELL")
end


and my initial read was perhaps that this adding up to the wrong value was the cause of it looping but looking through my logs I'm kind of thinking you're right and msdp.CHARACTER_AFFECTS never included item-generated SAVING_SPELL

EDIT: OK, this was totally my fault. The values aren't what are expected because I can't wear all items in the eqsets. Sorry :(
cnl
40 Prime Poster
 
Posts: 42
Joined: Wed Oct 21, 2020 12:16 am
Status: Offline


Return to General Chat (Registered)

Who is online

Users browsing this forum: No registered users and 9 guests

cron